Inspira Technology Group - Inspira Broadband - Nationwide Outage – Incident details

Inspira Broadband - Nationwide Outage

Resolved
Operational
Started 20 days agoLasted about 17 hours

Affected

Connectivity & Voice

Partial outage from 7:16 PM to 7:32 PM, Operational from 7:16 PM to 7:32 PM, Major outage from 7:32 PM to 9:27 PM, Operational from 9:27 PM to 11:51 AM

Inspira Broadband

Partial outage from 7:16 PM to 7:32 PM, Major outage from 7:32 PM to 9:27 PM, Operational from 9:27 PM to 11:51 AM

Inspira Leased Lines & EFM

Operational from 7:16 PM to 7:32 PM, Major outage from 7:32 PM to 9:27 PM, Operational from 9:27 PM to 11:51 AM

Updates
  • Postmortem
    Postmortem

    On the evening of 6th October 2025, broadband and leased line services experienced disruption due to a suspected DDoS attack targeting our core network. Some transit connectivity was temporarily disabled to reduce router load and stabilise the network, with additional DDoS protections subsequently implemented. Although further attacks occurred overnight, they were successfully mitigated without service impact, and all connections are now operating normally. Continuous monitoring remains in place to ensure ongoing stability.

  • Resolved
    Resolved

    This incident has been resolved.

  • Monitoring
    Monitoring

    Services have been stable for the last 45 minutes. We're continuing to gather the facts around this outage and will share these once fully understood. Services are currently deemed 'at risk' but stable. Should this issue re-occur this evening we'll post a further update here. This incident will remain open until tomorrow for further monitoring. Thank you for your patience whilst we stabilised the network and apologies for any inconvenience caused.

  • Update
    Update

    We're seeing services restored, please note this is still an active incident while our engineers continue to investigate.

  • Identified
    Identified

    We are seeing issues affecting multiple POPs. We are working hard to restore stability. Apologies as this may be impacting primary and secondary paths.

  • Update
    Update

    We are currently dealing with a connectivity issue impacting leased line and broadband circuits operating via Telehouse North. Apologies for the disruption caused. Please bear with us while we work to resolve this as quickly as possible.

  • Investigating
    Investigating

    Our monitoring systems have detected a widespread outage across the ITG network. This is being investigated as a priority. Further updates will be posted here. We apologise for any inconvenience this may cause.