M365 - Users may be unable to access their Exchange Online mailboxes or send and receive email messages.

Resolved
Degraded performance
Started about 1 year ago Lasted about 1 hour

Affected

Cloud Services
Microsoft 365
Updates
  • Resolved
    Resolved

    Final status: We’ve confirmed that rerouting EOP traffic away from the affected portion of infrastructure has successfully resolved the user impact.

    Scope of impact: Impact was specific to users who are served through the affected infrastructure in North America, Europe, and the United Kingdom.

  • Monitoring
    Monitoring

    Current status: We’ve successfully routed EOP traffic away from affected portion of infrastructure. We’re monitoring our systems and reaching out to previously affected users to confirm impact has been resolved.

    Scope of impact: Impact is specific to users who are served through the affected infrastructure in North America, Europe, and the United Kingdom.

  • Identified
    Update

    While our root cause investigation is ongoing, we're in the process of routing EOP traffic away from what appears to be the affected infrastructure as a potential mitigation strategy.

    This quick update is designed to give the latest information on this issue.

  • Identified
    Identified

    More info: Users may receive an error message including: “550 5.4.1 Recipient address rejected: Access denied” when attempting to send or receive messages.

    Current status: We’ve identified a potential Directory Based Edge Blocking (DBEB) issue that may be contributing to impact. We’re investigating this alongside our existing diagnostic data to determine our next steps.

    Scope of impact: Impact is specific to users who are served through the affected infrastructure in North America, Europe, and the United Kingdom.