Unable to login - Inspira ExpressTrack Service Desk

Resolved
Partial outage
Started 8 months ago Lasted about 5 hours

Affected

Customer Portals
Inspira ExpressTrack - Support Portal
Updates
  • Resolved
    Resolved

    Our software vendor has advised that they are no longer seeing occurrences of the account login errors, all clients should be able to successfully login now.

  • Monitoring
    Monitoring

    Our software vendor has identified the root cause of the login issues and has mitigated the problem. This is now being monitored before declaring as resolved.

  • Investigating
    Investigating

    Our software supplier is investigating a global issue that is affecting the ability of some users to log in. This is affecting our support team. If your support query is urgent we'll respond to you directly from our support mailbox.

    Customers may also find that they are unable to login to the help centre. If this occurs, please email your query to support@itg-uk.com and we'll pick this up manually.

    We are expecting our software vendor to provide further updates within the next hour. Apologies for any inconvenience this may cause.